Jump to content
My Monterey
Sign in to follow this  
ebb625

2001 220 Sport explorer 4.3 mercuiser duoprop

Recommended Posts

After engine is warm, occasionally the engine will not shut off. Also, the engine shut off switch does not work.

Any ideas why this is happening some times?

Share this post


Link to post
Share on other sites

After engine is warm, occasionally the engine will not shut off. Also, the engine shut off switch does not work.

Any ideas why this is happening some times?

 

What type of motor is it - fuel injected or carburetor?

When you say the motor will not shut off or the shut off switch doesn't work - how long does the motor stay on? - seconds? minutes?

Does it run extremely roughly when it is trying to shut down?

So how do you shut down if it keeps running?

 

If it is a carburetor motor - it sounds like an issue of very bad timing adjustment

When was the last time the motor was serviced?

Share this post


Link to post
Share on other sites

What type of motor is it - fuel injected or carburetor?

When you say the motor will not shut off or the shut off switch doesn't work - how long does the motor stay on? - seconds? minutes?

Does it run extremely roughly when it is trying to shut down?

So how do you shut down if it keeps running?

 

If it is a carburetor motor - it sounds like an issue of very bad timing adjustment

When was the last time the motor was serviced?

 

It has a carb. The engine runs great/smooth. Has lots of power. Starts quickly. Only every now and then it will not shut off. When it does happen, the kill switch also doesn't work and so I turn the key slightly like if I wanted to start. Then I can go back to off position with the key and the engine shuts off.

So far I've only replaced the ignition.

Share this post


Link to post
Share on other sites

It has a carb. The engine runs great/smooth. Has lots of power. Starts quickly. Only every now and then it will not shut off. When it does happen, the kill switch also doesn't work and so I turn the key slightly like if I wanted to start. Then I can go back to off position with the key and the engine shuts off.

So far I've only replaced the ignition.

 

 

Sounds like a strange problem.

I would suspect there might be a problem in the engine control module.

It is very unusual that the kill switch isn't working as this is obviously a major safety feature. I don't think its the kill switch because if this went open circuit (broken) you wouldnt be able to start the motor in the first place).

If its not a timing issuing, might be time to visit the volvo / mercruiser dealer to check the ECM

 

Any other responses?

 

Reagrds

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...