Jump to content
My Monterey
Sign in to follow this  
Aussie Heath

NAVMAN GPS/Sonar problem

Recommended Posts

Hi All

 

My Navman 8084 is playing up.

The Sonar/Fish Finder/Depth sounder doesn't seem to be working properly.

The colours look to be inverted, the depth indication is intermittent and unreliable and it doesn't map the bottom at all.

I haven't had the boat for very long and have never seen it working.

The boat isn't antifowled so the transducer hasn't been painted over.

 

I understand that this is a much maligned unit most of my enquiries with technicians have resulted in "its not worth repairing, just replace it!"

The GPS/plotter and the engine interface work really well so I don't want to simply bin it!

 

Any advice or words of wisdom would be appreciated (except for "just bin it!")

 

There is a photo of the screen in action if any one is interested.

 

Cheers

Hpost-22669-13146825779_thumb.jpg

Share this post


Link to post
Share on other sites

Hi all,

After much faffing around with this problem, it was a dead transducer.

it seems during transport on the truck a support block was positioned under the transducer. Oddly enough the transducer wasn't built to hold the weight of the boat.........

So in future if a technician says "just bin it" have another look, you might just find the problem with a bit of amateur troubleshooting.

 

Cheers

Heath

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...