Jump to content
My Monterey
AxRe

Active trim is not working

Recommended Posts

I have been battling this same issue.... The only way I get mine to work is, while underway once you have the boat up on plane at your desired speed, find the sweet spot while manually trimming up/down, once you're there press the up button on the active trim until you're in the middle (I think 3 bars up) then press the up and down buttons at the same time on the active trim until the lights stop blinking and it will lock in that sweet spot. thereafter it will work like it should and you can can increase or decrease the trim's sweet spot by pressing the active trim up or down a notch or two--this is why it's best to save the original position in the middle so you have room for adjustment as your boats load weight fluctuates (number of passengers, fuel increase/decrease, etc).  Issue with my boat is every time I turn my batteries off I have to reset the Active Trim, which I highly doubt is how it's supposed to work. Trying to figure this one out now... Hope this helps! 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...