Jump to content
My Monterey

llanigulfbreeze

Members
  • Content Count

    4
  • Joined

  • Last visited

Everything posted by llanigulfbreeze

  1. Finally found the solution. There is an access panel under the helm, not the breaker panel but a carpeted access panel that all the dash connections are run too. Every ground connection was loose, once tightened then everything works fine. The dealer and Monterey were no help. If you have electric problem this is the area I would look to first, you need to remove everything from under the helm and crawl in to find the panel. Simple fix but a little Loctite Threadlocker on the screws would have prevented this.
  2. Finally found the solution. There is an access panel under the helm, not the breaker panel but a carpeted access panel that all the dash connections are run too. Every ground connection was loose, once tightened then everything works fine. The dealer and Monterey were no help. If you have electric problem this is the area I would look to first, you need to remove everything from under the helm and crawl in to find the panel. Simple fix but a little Loctite Threadlocker on the screws would have prevented this.
  3. My 2021 M65 is having sporadic electrical issues, 3 times in the last month the GPS and gauges all lose power for a brief second and then come back on. It does not effect the tachometer or the main radio but does turn off the helm radio control. The engine operates without interruption. I have checked all the wiring connections and the problem occurs with either battery. The closest dealer is a 3 hour boat ride and I don't feel comfortable going that far in case this is a major problem. Any suggestions would be appreciated.
×
×
  • Create New...