Jump to content
My Monterey
Sign in to follow this  
Soonerjake

Jabsco manual pump head

Recommended Posts

Having trouble getting my head to pump. It makes a sucking sound when pumping it but no water in bowl. Someone suggested that the seacock was closed but I cant seem to find it. I think I have looked in all of the reachable places. Any help would be appreciated.

Boat is a 2006 268ss

thanks

Share this post


Link to post
Share on other sites

Inside the ski locker (forward section) you will see a small square hatch...inside that compartment is the shower sump, foward bilge pump and the toilet seacock. The seacock is made of Marlon and if it has not been moved in a long time it can be hard to get it to turn for the first time. Marlon is very tough- but do not use excessive force (such as a hammer!) as you can possibly break the handle off..... Just work it little by little and it will loosen.

Share this post


Link to post
Share on other sites

Forward section of the aft ski locker? or the ski locker in the bow area that has the screw out "lid" for access under the liner? btw it is a bowrider so not sure that I would have a shower sump. thanks I will look tomorrow when we get to the lake.

 

 

Inside the ski locker (forward section) you will see a small square hatch...inside that compartment is the shower sump, foward bilge pump and the toilet seacock. The seacock is made of Marlon and if it has not been moved in a long time it can be hard to get it to turn for the first time. Marlon is very tough- but do not use excessive force (such as a hammer!) as you can possibly break the handle off..... Just work it little by little and it will loosen.

Share this post


Link to post
Share on other sites

still haven't found it. by looking at it as close as I can it sure looks like it pulls water from the fresh water tank. Maybe the seal is bad on the pump???

 

Forward section of the aft ski locker? or the ski locker in the bow area that has the screw out "lid" for access under the liner? btw it is a bowrider so not sure that I would have a shower sump. thanks I will look tomorrow when we get to the lake.

Share this post


Link to post
Share on other sites
still haven't found it. by looking at it as close as I can it sure looks like it pulls water from the fresh water tank. Maybe the seal is bad on the pump???

 

 

It may pull from the freshwater. Whether it does or not, the Jabsco toilets are known for the seals in the pump to give out. You may have to order a seal kit from your dealer. In the 3 years that I owned my 250CR, I've had to replace the seals twice. A few folks at the marina have also had to replace theirs.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...